Follow

Using Fetch on the Web

 

Fetch is PensionPro's data query tool. The Fetch querying tool acts as an open database where users who are given access can create customized queries of their PensionPro data. All queries created in Fetch can be saved, shared, and exported to multiple formats. The File Menu allows easy access to saved queries, the saving of new queries and to the program options.

 

Tier Availability: Premium, Business
Security Rights Required: Access Query Tool

 

  Note: Some items may not be available in all tiers.

Menu:

 

Accessing Fetch

Security Rights Needed

Users will need the Access Query Tool Security Right to access Fetch. Fetch acts as an open database to users allowing access to all of their firm's data in PensionPro. For steps on how to add security rights to employees, please review Adding Employees and Security Rights.

Access from PensionPro

Fetch users can access Fetch directly from PensionPro from the Power Tools menu. Users accessing Fetch in this manner will need the Access Query Tool, and Access Power Tools security rights.

  1. From PensionPro, click Power Tools > Fetch.
  2. Fetch will open in the user's default browser.

Website Access

Users can access Fetch on the web, using the below URLs.

Fetch: https://fetch.pensionpro.com

Log Into Fetch

  1. Open the Fetch website.
  2. The user should enter their username in the Username field.
    • This is the same username the user logs into PensionPro with.
  3. The user should enter their password in the Password field.
    • This is the same password the user logs into PensionPro with.
  4. Click the Log In button.

Supported Browsers: PensionPro supports Fetch in the latest versions of Google Chrome, Edge, Firefox, and Internet Explorer 11.

When users log into Fetch, they should use the same login credentials they use to log into PensionPro. These credentials are linked between both PensionPro and Fetch. Should a user reset their password for either application, the user should use their new password to log into both applications.

Reset Password

  1. Click the Reset Password link on the Fetch login page.
  2. The user should enter their username in the Username field.
    • This is the same username the user logs into PensionPro with.
  3. Click Reset Password
  4. A temporary password will be sent to the email address associated with the username entered. The email will come from no-reply@devapps.pensionpro.com
  5. Carefully copy the temporary password from the email and paste it into the Password field of the Fetch Login page.
  6. The user can enter their username and click the Login button that appears.
  7. The user will be prompted to create a new password. Enter and confirm the new password and click Update.
    • Passwords need to be 8 characters with 3 of 4 of the following: uppercase letter, lowercase letter, number, and symbol.

 

Creating and Editing a Query

Users open fetch to a blank query upon login. Users can click on the Personal Queries or Shared Queries to open a previously saved query or click the Add Query button. Users can then use the Overview, Column Selections, Ordering & Sorts, and Filtering windows to create and maintain their query.

 

Open a New Query

  1. Click the Add Query button.
    • An Add a new query slider will appear.
  2. Enter a name for the query in the Name field.
  3. Enter a description for the query in the Description field.
  4. Select a repository for the query.
    • Users can select "My queries" or "Shared queries" to save the query as a personal or shared query respectively.
  5. Click Save.
  6. The new query's name, description, and repository will appear in the Overview window of Fetch.

 

Open a Previously Saved Query

  1. Click the Personal or Shared Queries button.
  2. Click on a Personal or Shared Query to open it.
  3. The query will load onto the Fetch site.

 

Overview Window

The Overview window is where users can edit the name, description, and repository of the query. Users can hide or display the Overview window by clicking the collapse button on the right side of the Overview header. Simply click on an Overview field to edit it.

 

Column Selections

The Column Selections window is where users can select the fields they want to appear in their query. Users can hide or display the Column Selections window by clicking the collapse button on the right side of the Column Selections header.

The Column Selections window contains the “tree” of fields that are available to be selected. The fields selected will be returned in the Result tab as columns of data. Users can select field by checking the box to the left of the field name.

When a column field is selected, the selected field will appear in the Ordering & Sorts window of Fetch. The selected field will also be available in the Filtering window as a field that can be filtered.

Selecting Fields

  1. Expand Field Selections to the level of data desired in the Column Selections window.
  2. Place a checkmark in the checkbox to the left of the field name to include the field in the query.

Null Fields 

Each time a node is expanded, a (+) or a (-) symbol is shown to the right of the node name. This determines how the records in that node will be returned in the query. For example, if the user selects two fields, Plan Name, and Project Name, with an option of minus on the Projects node, only plans that have projects will be returned. However, if the plus option is chosen on the Projects node, all plans will be returned, but some might contain a blank for the Project Name because there are no projects in the system for that plan.

 

Ordering & Sorts

The Ordering & Sorts window is where users can refine their query by reordering field columns, add sorting and select whether to display a column or not. Users can hide or display the Ordering & Sorts window by clicking the collapse button on the right side of the Ordering & Sorts header.

Ordering

Users can click and drag the six-dot toggle to the left of the field name in the Column bar to re-order their field columns for their results.

  1. Click the six-dot button to the left of the field name under the Column header of the Ordering & Sorts window.
  2. Drag the field to the desired column location. Fields displayed from top to bottom of the column header will appear left to right on the query results page.

Sort type\Order

Users can add sorting to their query by clicking on the Sort type\Order button to the right of the field name in the Ordering and Sorts window.

  1. Click the Sort type\Order button to the right of the field name in the Ordering & Sorts window to add sorting to the field.
    • Users can then add a sort type, change sort order, and select whether to show the column in the query results.
  • Toggle Sort Type: Users can toggle through No Sort Type, Ascending, or Descending sort selections by clicking on the Sort type\Order button.
  • Change Sort Order: If multiple fields have sorting added, users can click the Order arrow buttons or enter a number in the window to the right of the sort selection to update the order fields are sorted.

Show Column

Users can click on the On/Off toggle to select whether or not the field is displayed

 

Filtering

The Filtering window is where users can add filters to fields to enhance their query and limit results. Users can hide or display the Filtering window by clicking the collapse button on the right side of the Filtering header.

Add Filters

  1. In the Filtering window, click the (+) Add new rule button to add a filter.
  2. Select a field to filter on in the Column section dropdown.
  3. Select an operator to filter by in the Operator column dropdown.
  4. Select a value to filter by for this filter in the Value column dropdown.

Add Filter Groups

Users can add filter groups to control how their filters are utilized.

  1. Click the Add new group button to add a new filter group.
  2. An And/Or toggle will appear.
    • Selecting And will control results so that they must adhere to each of the filters entered below the And Filter Group.
    • Selecting Or will control results so that they must adhere to any of the filters entered below the Or Filter Group.
  3. Users can add additional filters under the Filter Group.

 

Using the Toolbar

The toolbar can be found in the grey bar to the left of the Fetch. The toolbar is where users can access their profile, Library Queries, Shared Queries, Personal Queries, and add new queries.

Profile

The Profile is where Fetch users can view their Login name, change their password, update their color scheme for Fetch, and provide feedback on Fetch.

  1. Click the Profile button in the lower lefthand corner of the toolbar.
    • Change Password
      1. Click the Change Password link.
      2. The user should enter their current password in the Password field.
      3. The user should enter their new password in the New Password field and confirm that password in the Confirm New Password Field.
      4. Click Save
        • The user can Cancel if necessary.
        • The new password entered will be what the user logs into PensionPro with in addition to Fetch.
    • Update Color Scheme
      • Users can click the Color Scheme dropdown to change the shading of the Fetch Website.
      • Selections include light and dark.
    • Give Feedback
      1. Click on the Give Feedback link to provide PensionPro with feedback on the Fetch App.
      2. Enter a comment in the Comment section.
      3. Click Submit.

Library Queries

The Library Queries button is where users can access pre-made queries that may be useful or provide a starting point for users to update to their needs. PensionPro is currently developing a library of queries to be selected from this menu.

  1. Click the Library Queries button.
  2. Click on a query to open it.

Shared Queries

Queries saved as Shared Queries will appear in this menu. These queries can be edited by any Fetch user in the user's firm. Users may want to keep a copy of a shared query as a backup by saving the copy as a Personal Query.

  1. Click the Shared Queries button.
  2. Click on a Shared Query to open it.
    • Shared Queries saved on the desktop version of Fetch will appear here.
  3. The query will load onto the Fetch site.

Personal Queries

Queries saved as Personal Queries will appear in this menu. Personal Queries saved by the user are only accessible to that user.

  1. Click the Personal Queries button.
  2. Click on a Personal Query to open it.
    • Personal Queries saved on the desktop version of Fetch will appear here.
  3. The query will load onto the Fetch Site.

Add Query

Users can click the Add button to start a new query.

  1. Click the Add Query button.
    • An Add a new query slider will appear.
  2. Enter a name for the query in the Name field.
  3. Enter a description for the query in the Description field.
  4. Select a repository for the query.
    • Users can select "My queries" or "Shared queries" to save the query as a personal or shared query respectively.
  5. Click Save.

 

Using the Action Menu

The Action menu is the bar at the top of the Fetch screen that allows users to run, save, or perform other actions for their query.

Execute a Query

Once users create their query, they can execute the query to see their results. Simply click the Execute query button at the top of the Fetch screen.

  1. Click the Execute Query button.
  2. Fetch will open to the Query Results page.
    • The results page displays up to 100 records per page.
    • Return to Query Builder: Users can click the Back button to return to the Query Builder.
    • Export Query Results: Users can click the Export Query Results button to export their query results to xls, xlsx, or csv file formats.
      1. Click the Export Query Results button.
      2. Enter a File Name for the exported results in the File Name field.
      3. Select an extension. Users can export their query results to xls, xlsx, or csv file formats.
      4. Click Export. The file will download from the user's default browser.

 

Save a Query

Once a user creates their new query, they can save the query. Simply click the Save Query button. The Query will save based on the parameters laid out in the Overview window.

Duplicate a Query

Users can duplicate an open query to copy it.

  1. Open a Query.
  2. Click the Action button (three dots) from the Action menu.
  3. Click Duplicate.
  4. A popup will appear. The duplicated query name will default to the name of the duplicated query with "Copy" appended to the end of the original query name.
  5. Click Duplicate. 

Delete a Query

Users can delete a saved query.

  1. Open a Query.
  2. Click the Action button (three dots) from the Action menu.
  3. Click Delete.
  4. A popup will appear. Click Yes, Delete to confirm deletion.

Clear Columns

The Clear Columns button will clear any and all selected columns from the query. Doing so will remove all filtering and orderings as well.

  1. Open a Query.
  2. Click the Action button (three dots) from the Action menu.
  3. Click Clear Columns.
  4. A popup will appear. Click Ok to confirm.

Clear Filters

The Clear Filters button will remove any filters the user had in their query.

  1. Open a Query.
  2. Click the Action button (three dots) from the Action menu.
  3. Click Clear Filters.

Clear Order and Sorts

The Clear order and sorts button will remove any selected order or sort options selected for the query.

  1. Open a Query.
  2. Click the Action button (three dots) from the Action menu.
  3. Click Clear order and Sorts.

Help

Should users need more information on Fetch, they can click the (?) Help button to open the Help Center and link to Fetch articles.

 

Frequently Asked Questions

  • Is it possible to filter on a field selection, but hide the field in the report so it doesn't display in the results? Yes. To add a field as a filter without displaying it in the report, Select a field from the Column Selections window and click the Show Column toggle to "Off" on the Ordering and Sorts window. The user can then select that field in the Filters window as a selection without the field appearing as a column in the query results.
  • Can I grant access for some users to view shared queries, but not others? Currently, any user that has access to Fetch can view and edit shared queries. The only way to restrict access to a saved query is to save it as a Personal Query.
  • Can I control who has rights to edit a shared query? Currently, any user that has access to Fetch can edit a shared query. There isn't a separate right to control which users can edit a shared query.
  • Can the Fetch queries be made to look more like the standard reports in PensionPro? Currently Fetch does not display the color format, date generated and title as seen in the standard PensionPro reports. Users can export the Fetch results to excel and format the report as desired.
  • I cannot find To-Dos in Fetch, where are they located in the Fetch "tree?" To-Dos are not currently included in Fetch.

 

 

Return to Top

Feature feedback

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments