Follow

Creating Merge Documents

 

The Merge Documents tool allows PensionPro users to automate the generation of their firm's client engagement agreements, participant forms, valuation summaries, and more, pulling their data directly from PensionPro. Users can create a series of templates, containing merge fields that pull their data from PensionPro into a personalized document. Those completed documents can then either be downloaded or directly uploaded to PensionPro.

 

Tier Availability: Business

Add-On Availability: SalesPitch

Security Rights Required: Access Merge Documents, Create Merge Documents

*The Access Merge Documents and Create Merge Documents rights must be added to employees before they have access to the Merge Documents feature. For directions on how to add security rights, click here.

 

Menu:

 

The Merge Documents tool is found by clicking Communications > Merge Documents.

There are two steps to creating a Merge Document. First, users must create and Edit the Template. Once the template is created, users can create the Merge Document.

Add a Merge Document Template

Security Rights Required: Access Merge Documents

 

  1. From the Application menu, click Communications > Merge Documents.
  2. The Merge Documents Templates site will open in the user’s default browser.
    • PensionPro supports the latest versions of Chrome, Edge, Firefox, and Internet Explorer 11.
  3. Click on the Add button to the right of the grid to create a new Template.
  4. An Add New Template popup will display. At this time a file is not required to be uploaded.
  5. Enter the Name of the Template, Description, the Data Source the file will pertain to, the Extension to be created (PDF or Docx), the Action (Download or Upload to PensionPro) and if the template can allow missing data.
    • The Template File can remain empty. 
    • Users have access to Contact, Distribution, Plan, Project, and SalesPitch data sources with the Merge Document feature.
      • Users can add Document Specifications merge fields if they selected the Plan Source.
    • Users have options to deliver their Merged Documents through different Actions.
      • Download: Users can select Download to simply download the finished Merge Document.
      • Upload to Plan, Project, Distribution or Proposal Files: Users can select to upload the file to Plan Files, Project Files or Distributions Files when working with the Plan, Project, and Distribution Data Sources respectively.
        • When sending to Plan Files, users can select to send to Plan Administrative, Plan Fiduciary, and Plan Legal Files subtabs for a Plan.
          • Users can then select the appropriate File Type the Merged Document will appear under on the Plan Files tab in PensionPro.
        • When Sending to Project Files, users can select the File Type List Value the Merged Document will appear under in the Project Files tab of a Project in PensionPro.
        • When Sending to Distribution files, users can select the File Type List Value the Merged Document will appear under in the Distribution Files tab in PensionPro.
        • When Sending to Proposal files, users can select the File Type List Value the Merged Document will appear under in the Proposal Files tab in PensionPro.
      • Send Using Email: Users can select to send their Merged Document through email. Selecting "Send using Email" will open text boxes for default Subject and Body text that will appear in a preformatted email when the Merge Document is sent.
      • Send Using Secure File Exchange: Users can select to send their Merged Document through the Secure File Exchange feature. Selecting "Send using Secure File Exchange" will open a text box for a default Message text box that will appear when the user sends their Merged Document through Secure File Exchange.
    • When Allow Missing Data is switched to "Yes" users can create a Merge Document where a Merge Field is missing data. 
    • When Allow Missing Data is switched to "No" users must fill in any missing data in PensionPro before the Merge Document can be created. 
  6. Click Save to proceed with creating the new template.
  7. Once the template is named it will display on the Merged Documents Templates screen. Click on the Template Name to highlight the template, and then click the Edit button to the top-right of the grid to continue editing the template.

 

Note: If users need help adding a merge field to their Word document, they can find directions here or Microsoft Merge Field syntax here

Add a Merge Field to a Word Template:

Users need to add Merge Fields to their Word template. To do so in Word:

  1. Click Insert > Quick Parts > Field.
  2. In the Fields Names grid, select "MergeField"
  3. Paste the Merge Field from the PensionPro Merge Documents Templates > Field field tab into the Field Name box in Word.
  4. Save the Word template.
  5. To add the Word template to a Merge Document Template, click once on a template record from the Merge Document Templates grid to highlight it.
  6. Click the Edit button located in the upper-right corner of the Merge Document Templates grid. This will open the Template details > Home tab screen.
  7. Click on the Edit button located in the upper-right corner of the Template > Home Tab. This will open the Edit Template pop-up window.
  8. Click the File button next to the Template File field to upload a Word document template to the PensionPro Merge Document Template.
    • NOTE: If a merge field is used that is not recognized by PensionPro, an error will display. The field name or format will need to be corrected in the word document to proceed.
    • Be sure to not add any leading or trailing spaces in the merge field name.
  9. Click Save.

 

 

Edit a Merge Document Template

Security Rights Required: Access Merge Documents

  1. From the Merge Documents Template screen, click once on a template to highlight it and click the Edit button.
  2. The Template page will now display with three tabs. Here users can click on the appropriate tab to make their changes. Click Save when complete.
    • Home Tab: On the Home tab, users can gather general information on the Merge Document template. Here, users can delete the template, rename the template, and change the Description, Data Source, Extension, Action, if the Merge Document allows missing data and upload a new or updated file. To upload or update a file, simply click the File button next to Template File and upload the completed world template file.
      • Name: Enter the template name.
      • Description: Enter a description for the template.
      • Source: Select the Source of the Data for the Merge Fields.
        • Contacts
        • Distribution
        • Plan
        • Project
        • SalesPitch
      • Extension: Select the extension the Merged Document should be created as (.pdf or .docx)
      • Action
        • Download: Users can select Download to simply download the finished Merge Document.
        • Upload to Plan, Project, Distribution or Proposal Files: Users can select to upload the file to Plan Files, Project Files or Distributions Files when working with the Plan, Project, and Distribution Data Sources respectively.
          • When sending to Plan Files, users can select to send to Plan Administrative, Plan Fiduciary, and Plan Legal Files subtabs for a Plan.
            • Users can then select the appropriate File Type the Merged Document will appear under on the Plan Files tab in PensionPro.
          • When Sending to Project Files, users can select the File Type List Value the Merged Document will appear under in the Project Files tab of a Project in PensionPro.
          • When Sending to Distribution files, users can select the File Type List Value the Merged Document will appear under in the Distribution Files tab in PensionPro.
          • When Sending to Proposal files, users can select the File Type List Value the Merged Document will appear under in the Proposal Files tab in PensionPro.
        • Send Using Email: Users can select to send their Merged Document through email. Selecting "Send using Email" will open text boxes for default Subject and Body text that will appear in a preformatted email when the Merge Document is sent.
        • Send Using Secure File Exchange: Users can select to send their Merged Document through the Secure File Exchange feature. Selecting "Send using Secure File Exchange" will open a text box for a default Message text box that will appear when the user sends their Merged Document through Secure File Exchange.
      • Users can click the File button to upload a completed word document template. Simply click the File button next to Template File and upload the completed word template file.
        • NOTE: If a merge field is used that is not recognized by PensionPro, an error will display. The field name or format will need to be corrected in the word document to proceed.
        • Be sure to not add any leading or trailing spaces in the merge field name. 
    • Fields Tab: This tab displays the merge fields available for the data source that was selected in the Home tab.
      • The fields are collapsible and may be double-clicked on to copy to a clipboard.  Users can paste the merge field to their word document or use a macro to convert the pasted text into a merge field.
      • Users may also select a merge field to add to the file name. Just select the merge field and click on the up arrow to the side of the file name. This will allow users to name each file with its corresponding data.
      • If merge fields are typed into a word document, those merge fields must appear exactly as they are displayed in the Merge Fields list.
    • Filters Tab: If a field references more than one piece of data, users may choose the default data to display on the merged file, here by creating a filter. The other selections will remain in a dropdown while creating the file in the Create Merged Documents wizard.
      • Click the Edit button and an Edit Filters pop-up will appear. Select the data to filter from the dropdowns available and click Save.

 

 

Note: If users need help adding a merge field to their Word document, they can find directions here or Microsoft Merge Field syntax here

Add a Merge Field to a Word Template:

 

Users need to add Merge Fields to their Word template. To do so in Word:

  1. Click Insert > Quick Parts > Field.
  2. In the Fields Names grid, select "MergeField"
  3. Paste the Merge Field from the PensionPro Merge Documents Templates > Field field tab into the Field Name box in Word.
  4. Save the Word template.
  5. On the Merge Document Template screen, click the File button to upload a completed Word document template to the PensionPro Merge Document Template. Simply click the File button next to Template File and upload the completed word template file.
    • NOTE: If a merge field is used that is not recognized by PensionPro, an error will display. The field name or format will need to be corrected in the word document to proceed.
    • Be sure to not add any leading or trailing spaces in the merge field name.

 

Using the Merge Document Template Toolbar 

To help users search for templates in the Merged Document Templates grid, multiple tools are available to assist in organizing templates.

  • Export: Users can export a list of their templates by clicking the Export button. An excel file will download displaying the Name, Description, File, Data Source, File Type, Extension, Created On Date, Created By information for each template.
  • Grouping: Users can click the Group button to group their templates. Click the Group button and drag and drop column headers to the bar above the column headers to group templates in the order grouped. Click the Ungroup button to undo and grouping.
  • Filter: Users can toggle filtering by clicking the Filter button to the right of the grid. A filter button will appear in the right-hand side of each column heading. Clicking on this button will open a pop-up that will allow the user to search on a specific word or words. 
  • Sorting: By clicking on a column heading the user will be able to sort by that column. Click the Clear Sort button to clear any sorting.
  • Refresh: This button refreshes the screen to account for any recent updates to Merged Document Templates. 
  • Delete: This button deletes a template. To delete a template, highlight the template and click the Delete button. Once the template is deleted it cannot be retrieved.
  • Edit: This button allows the user to make changes to a template. To edit a template, highlight the template and click the Edit button.
  • Clone: This button allows the user to copy a template. Highlight a template and click the Clone button. An Add New Template pop-up will appear. Users can make their selections and save the cloned template.
  • Add: This button allows the user to create a brand new template. Clicking the Add button will cause an Add New Template pop-up to appear. Users can make their selections and save the new template.
  • Download: Clicking the document name under the File column will download the document used for the Merged Document Template.

 

Create a Merge Document

Security Rights Required: Create Merge Documents

 

Now users are ready to create their document.  In the PensionPro application, access the data to create the merged document for.  For example, If the word document created is for a fee schedule that is listed on a plan, search for the plan in which the fee schedule will be created for.  Click on the Create Merged Document Wizard button in the header on the top right-hand side of the Plan Details grid.

Note: The Merged Wizard button to create merged documents has been placed in the header of each Data Source in which merge fields are available for. 

Step 1

  1. Click the Create Merged Document Wizard button.
  2. The Merged Document Creation Wizard will now display in the user’s default browser and land on Step 1 – Getting Started.
    • PensionPro supports the latest versions of Chrome, Edge, Firefox, and Internet Explorer 11.
  3. In Template Name, select the template to create the document.
  4. In Extension, select the file type the document will be created.
    • The type chosen when setting up the template will be the default selection, however, this can be changed.
  5. Select an Action for the document. This will be how the Merged Document is delivered once created.
    • Download: Users can select Download to simply download the finished Merged Document.
    • Upload to Plan, Project, Distribution or Proposal Files: Users can select to upload the file to Plan Files, Project Files or Distributions Files when working with the Plan, Project, and Distribution Data Sources respectively.
      • When sending to Plan Files, users can select to send to Plan Administrative, Plan Fiduciary, and Plan Legal Files subtabs for a Plan.
        • Users can then select the appropriate File Type the Merged Document will appear under on the Plan Files tab in PensionPro.
        • Users can select to Show on PSL, Show as Accessed, add an Access Date, or Archive the file.
      • When Sending to Project Files, users can select the File Type List Value the Merged Document will appear under in the Project Files tab of a Project in PensionPro.
        • Users can select to Show on PSL, Show as Accessed, add an Access Date, or Archive the file.
      • When Sending to Distribution files, users can select the File Type List Value the Merged Document will appear under in the Distribution Files tab in PensionPro.
        • Users can select to Show on PSL, Show as Accessed, add an Access Date, or Archive the file.
      • When Sending to Proposal files, users can select the File Type List Value the Merged Document will appear under in the Proposal Files tab in PensionPro.
    • Send Using Email: Users can select to send their Merged Document through email. Selecting "Send using Email" will open text boxes for default Subject and Body text that will appear in a preformatted email when the Merged Document is sent.
      • The system will open the email in the user's default email client.
    • Send Using Secure File Exchange: Users can select to send their Merged Document through the Secure File Exchange feature. Selecting "Send using Secure File Exchange" will open a text box for a default Message text box that will appear when the user sends their Merged Document through Secure File Exchange.
  6. Click Continue to proceed to Step 2 of the wizard.

Step 2

  1. Step 2 will give users a glance of how their data will populate on their document for the merge fields used. If there is more than one data set returned, filters will display above the grid and the data will appear in the dropdown. 
    • Once the data source to use is selected, click on the Refresh button to re-populate the merge fields with the correct data to review.
    • Missing Data for the applicable Merge Fields will display in the Merge Value column as "***MISSING DATA***".
      • If Allow Missing Data is set to "No" for the Merged Document Template, users will need to populate any missing data.
      • If there are merge fields with missing data in PensionPro, there are two ways to fix the missing data.
        • Go into PensionPro and populate the fields.
        • Remove the fields from the merged document.
        • Until missing Data is updated in PensionPro, the Create Button on the Create Merged Document wizard for Step 2 will remain greyed out.
  2. Once the fields with Missing Data are fixed, click refresh to see the updates made.
  3. Click Continue to proceed to Step 3 to review how the document will be created.

Step 3

  1. Review how the merge document will be created. Click Create to progress to Step 4 and create the merged document.
    • Users can click Start Over to return to the Merged File Creation Wizard Getting Started page.

Step 4

  1. Upon moving to Step 4 the merged document will create as per the parameters outlined in Step 3.
    • If the user originally chose to download the file, it will automatically download into the user's default download browser.
    • If the user originally chose to upload the file to PensionPro, the file will now be located to the location selected in Step 1.
    • Users can click the Download the File button to re-download the document if needed.
    • If Send using Email was selected as the Action, an eml file will download on the user's browser. Users can select to keep and open the email. Once they make any necessary changes, and select a recipient, they can send the email.
    • If Send using Secure File Exchange was selected as the Action, Secure File Exchange will open in the user's default browser. The Merged Document will already be added to the files section.
      • Users can select additional files to send using the files button.
      • Users can select the recipient(s) the Secure File Exchange should be sent to. 
      • Users can click back on the Create Merged Documents wizard to download the file if desired.
      • Users can click back on the Create Merged Documents wizard to click on the Send Secure File Exchange button to send additional Secure File Exchanges if desired.

 

Frequently Asked Questions

 

  • Q: How do I know what tier I'm on?
    A: From PensionPro, click on the Help menu and click About. This will display for you the current tier you are on.

 

  • Q: My images are not appearing when I create a merge document as a PDF. What am I doing incorrectly?
    A: The image may actually be set up as a series of Word objects grouped together rather than a single image. If you click to open the grid lines on the word template and right-click you can ungroup them. After ungrouping the images, save the updated Word template and upload it to your Merge Document Templates. The image should then appear when creating the Merge Document in the future.      

 

  • Q: Can number merge fields be formatted?
    A: Yes. This is done in the Word template.

 

  • Q: Can this feature be used to merge SH Notices into the Communications tab which we create in batch through FTWilliam?
    A: No, the merge feature was designed to create single merge documents only. Importing of batched documents would be part of another feature.

 

  • Q: Can we import pre-existing word templates into PensionPro?
    A: Yes. Your current templates will be importable, you'll just want to verify that the merge fields line up with the data silo in PensionPro.

 

  • Q: Can we merge more than one plan at a time?
    A: Not currently, but we are planning on working on multiple document merge after we complete our initial releases for single merge documents.

 

  • Q: Can you merge into Excel Files as well?
    A: No. You can merge into PDF and DOCX

 

  • Q: What about our documents with conditional logic? Will those work in here?
    A: Yes. Conditional logic will be recognized within the templates. You can create conditional logic in your Word file. 

 

  • Q: For data type - is it not possible to select more than one?
    A: You can choose from multiple nodes of data when creating a merge document, but for our first release it will handle one set of data for each type you select.

 

  • Q: How you find the merge code to put in your document?  
    A: The merge code is copied from the Fields tab of the template editor. You can then use the insert feature of Word to paste the field name into a word document template.

 

  • Q: Is there any way to sort or categorize the available templates?
    A: Yes. You can Sort, Group and Filter the grid containing the Merge Templates.

 

  • Q: The document merge is a one to one merge or can it be a multiple contact (etc) merge?
    A: Currently, it is a single contact merge, but we are planning on enhancing that as we release new versions throughout the first quarter of next year.

 

  • Q: What were the new number types for project templates again? currency, and... what and what? 
    A: The new types added are Integer, Currency and Number.

 

  • Q: Can we control who has access to make changes to templates?
    A: Yes. Document Merging will have two associated security rights. One will control a user's access to merge documents (Access Merge Documents), the other will control the user having access to make changes to templates (Create Merge Documents).

 

  • Q: Will this be available to use for distributions as well?
    A: Yes. Distributions are available as a data source for merging into your documents.

 

  • Q: Once you merge in a word doc, if you want to make changes to the language in the template, how do you update it?
    A: To edit, you can download the document template from the templates screen or locate your original source document, make the changes and upload it to the merge template.

 

  • Q: Can you also print these out as Word Docs as opposed to just PDF
    A: Yes you can create a merged PDF document

 

  • Q: Will we be able to auto-upload the file to PlanSponsorLink?
    A: Yes. One of the options to save the file is to upload it directly to PlanSponsorLink.

 

  • Q: What happens if all the fields are not filled in?
    A: For our first release you will need to provide the data for all fields before you can generate a document. In subsequent releases, were are going to allow for the template to be created without all field data if you allow it.

 

  • Q: Since there are no project fields in SalesPitch how can this be used in SalesPitch?
    A: All of the data that exists on the Opportunity and Proposals are available to merge. For example, you can merge the Fee Schedule, Investment Provider and Contacts into a document.

 

  • Q: Can you send the document created from SalesPitch via Secure File Exchange too?
    A: You can by generating it as a file and then dragging it into a Secure File Exchange. We are also going to be automating it so that it is an action that can be chosen as part of the merge.

 

  • Q: Is there a limit on document size, or how many templates we can have?
    A: No. You will be able to create as many templates as you need, and there is no limiter on the size of the file that can be uploaded

 

  • Q: I am on the Business Tier, but I don't see the Merged Documents feature anywhere.
    A: In order to use the Merged Documents feature, you will need to be on the Business Tier and using at latest version 1.30 of PensionPro. Users must also have either the Access Merged Documents Security Right and the Create Merged Documents Security Right to maintain Merged Document templates and create Merged Documents respectively.

 

 

 

 

 Feature feedback

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments