Follow

Getting Started with PensionPro Track

Welcome to PensionPro Track! This article provides information to give users the basics when working within the Track tier of PensionPro. Users will want to complete the information in order. For additional information, please feel free to access the Associated Articles link.

 

Tier Availability: Track

Add-On Availability:  SalesPitch, PlanSponsorLink

Find information on the following topics by clicking the links below:

 

Installing PensionPro   top^

To get started with PensionPro, the software needs to be downloaded and installed.

  1. Open a browser and enter https://workflow.tpaworkflow.com in the URL field.
  2. Click the Install Button and follow the prompts to install PensionPro.
  3. PensionPro will Launch after the Installer Finishes.

 

 Accessing PensionPro   top^

Once PensionPro has been successfully installed, double-click on the PensionPro swan icon from the desktop to log into the system. 

  1. From the user's desktop, double-click on the PensionPro icon to open the login screen.
  2. Enter the Username that was provided in the Getting Started with PensionPro Track! email.
  3. Click on the “Don’t Know Your Password” link to receive a temporary password.
  4. Enter the temporary password received in the email.
  5. Create a new password. Passwords must be a minimum of 8 characters and contain at least 3 of the following 4 items: uppercase letter, lowercase letter, number, symbol (~!@#$%^&*).

 

 

Adding Employees   top^

Once PensionPro has been successfully installed and accessed, a user with the correct security rights can begin to add employees to PensionPro. Below is information on how to add employees and adjust security rights for employees.

Security Rights Required: Add/Edit Employee

How to Add an Employee

  1. From the Application menu click on Data > Employees > Add an Employee.
  2. The Add Employee slider menu will appear. Complete the fields on the slider menu and click Save. First Name, Last Name, Email, and User Name are required fields. All required fields will be listed at the bottom of the slider and will be removed as each required field is completed. The Username should be employee’s email address.
  3. Click on Application > Refresh Security to add the Employee to the Company Directory.

Assigning Security Right

Security Rights Required: Add/Edit Employee

To access the Employee Details screen

  1. Click on the Company Directory on the left.
  2. Locate the Employee’s name and double-click.
  3. Click on the Security Rights tab.
  4. Click on the Add button.
  5. The Add Security Rights slider menu will appear.
  6. From the dropdown list select the Security Rights to be added or select Add All Rights and click the Add button to the right of the dropdown to add the right(s).
  7. Click Save when complete.

Below is a list of security rights and their function:

 Security_Roles.png

 

List Values  top^

Security Rights Required: Maintenance

Now that the Employees are set up in the system, list values need to be added. List values are extremely important because these values allow the user to customize certain fields to fit the company’s needs. They are used in dropdown menus to provide a systematic value structure for various fields in PensionPro. Please note that many of the List Values in the system need to be set up prior to importing data to complete the import.

For information on adding list values, please click here to be directed to our article Maintaining List Values.

 

 

Importing Data into PensionPro  top^

Security Rights Required: Access Power Tools

So users can import their Clients, Plans, Plan Contacts, Employer data, Investment Provider information at once, they could use the Express Import Power Tool. Users can find directions on how to use the Express Import, in our article Using the Express Import Tool.

 

 

Using the Search Feature  top^

Once data is imported into PensionPro, users can find data by using the search feature. The Search Feature allows a user to find information quickly and easily in PensionPro. Users can find directions on how to use the Search Feature, in our article Using the Search Features.

Security Rights Required: None

Search Location:

  1. In the Search bar, located in the upper right-hand corner of any screen in PensionPro.
  2. The Search tab located in the left-hand corner, to the right of the Dashboard tab.

Search Display: 

The search results will be displayed on the Search Dashboard under the following Categories:

  • Companies
  • Clients
  • Plans
  • Contacts

The Search Dashboard display can be customized to show only the data categories desired.  Customize the view by clicking the Search Categories dropdown on the right-hand side of the Search Tab and clicking on a category to select or deselect it. Click Save to save any changes made.

How to Search:

  1. In the Search box or in the Search tab enter at least three characters (users can search alpha and numeric characters). If more than three characters are entered, it will narrow the number of records returned.                                  
  2. The search feature will return matching data from the following fields:
    • Company: Company Name
    • Client: Client Name, Client ID, Search Text
    • Plan: Plan Name, TPA Plan ID, Search Text
    • Contacts: Full Name, Company Name, Email Address, Phone Number
  1. Select the results returned in any Search Category by double-clicking on the name.
  • To include data from Terminated or Inactive sources, click the gear button to the right of the Search Category header and check the box to expand the search to include this information.

 

 

Plan Cycles  top^

Plan Cycles in PensionPro are used to store annual recurring plan information. Plan Cycles can be found by searching for a Plan, double-clicking the Plan Name from the search results and selecting the Plan Cycle tab under Plan Details. To access a specific Plan Cycle, double-click on the appropriate Plan Cycle record from the Plan Cycle tab. This will open the underlying fields within the Plan Cycle.   

 

Security Rights Required: Add/Edit Plans, Access Power Tools, Add/Edit Plan Cycles

Plan Cycles can be imported into PensionPro using the Plan Cycle Data Import.

  1. From the Applications > Power Tools > Import > Plan Cycle Data.
  2. Click on the Download Template button to download an empty template.
  3. Complete the template.
  4. Once the template is complete, click on Applications > Power Tools > Import > Plan Cycle Data.
  5. In the “I want to” dropdown menu choose Import Data.
  6. Click on the Import file button and choose the file to import.
    • All successful records will show in the Success Tab while any records that failed to be created will be displayed in the Failed Tab.

Plan Cycles Fields:

General tab

The General tab of Plan Cycles is where users can find basic information about the Plan Cycle.

Filings tab

The Filings tab of Plan Cycles is where users can find dates for the various filings and submissions for 5500 information.

Milestones tab

The Milestones tab provides information on the high-level events that take place during the Annual Data Collection process.

As Milestones information is entered, users can track that information on the Milestones Dashboard.

The Milestones section of Plan Cycles is available for users on the Milestones dashboard of PensionPro. The high-level events that take place during the annual data collection process of a plan are displayed on this dashboard by Plan Name and Plan Year Period. When users open PensionPro, the screen opens to the Milestones Dashboard.

For information on using and customizing the Milestones Dashboard, please read our article Using the Milestones Dashboard.

 

 

Reports  top^

Once data is entered in PensionPro, users can report on that information. PensionPro has made this easy by providing Reports which are accessible from the Application Menu.

Security Rights Required: None

There are many useful reports that are pre-built in PensionPro for users to utilize to assist with reporting needs. Below are brief descriptions of reports found in PensionPro. Please note that not all fields displayed on reports are included on PensionPro Track. 

Reports can be accessed by clicking Reports from the Application Menu of PensionPro. Users will find that reports are organized into various sections including Contacts, Clients and Companies, Mailing and Labels, Plans, and Management Reports. To access Management Reports, users need the Management Reports right. Users can find more information on specific reports in our article, Navigating PensionPro Reports.

Contacts

Clicking Reports > Contacts allows the user to select from a list of reports pertaining to Contact data. This section provides reports on contact lists, contacts missing data exception reports and contact investment listing reports.

Clients and Companies

Clicking Reports > Clients and Companies allows the user to access Client and Company reports. This section contains reports such as client lists, clients missing data exception reports, company addresses and numbers reports. This section also provides reports that detail client to plan links.

Mailing and Labels

The Mailing and Labels section of Reports is accessed by clicking Reports > Mailing and Labels and it provides exactly as the title suggests. Users can access these reports to print out contact, plan contact and client mailing information.

Plans

Users can click Reports > Plans to choose from a list of reports that pertain to plan information. Users can find reports such as plan lists, plans by employee role, plans by contact role, plans missing data exception reports, plan services, investments, and plan cycle information.

Management Reports

The Management Reports section allows managers to effectively report on system and data information. This section is accessed by clicking Reports > Management Reports and is only accessible if the user has the Management Reports security right. The Management Reports section is comprised of three subsections including Maintenance Reports, Charts and Graphs, Data Export and Metrics. The Maintenance Reports allow managers to report on List Values, security roles, user activity logs, and plan termination to deactivation information. The Charts and Graphs reporting section allows managers to see a chart of the number of plans added per month and various totals. The Data Exports section provides managers with the ability to export their data from PensionPro into organized templates. The Metrics Reports section allows managers to report on plan counts, and plan cycles. 

 

 

Associated Articles  top^

 

 

 Feature feedback

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments