Follow

Entering and Importing Plan Cycle Data

Plan Cycle Data in PensionPro can be completed  in two ways: either a user can manually enter the information on the Plan Cycle screen or it can be imported using the Plan Cycle Data import tool.  If a user enters the  data manually and decides to import data later, the import routine will allow the user to skip or overwrite existing data.

Tier Availability:  Track, Core, Team, Essential, Premium, Business  
Security Rights Required: Access Power Tools, Add/Edit Plan Cycles 

  Note: Tabs and fields will vary depending on the tier the user is on.

Manually Entering Plan Cycle Data 

A user can edit Plan Cycle Data records for Plans via the Plan Details>Home>Plan Cycles Tab or the Project>Plan Cycle Tab for Annual Administration projects.  

Adding Plan Cycle Data from Plan Details: 

  1. From the Plan Details > Home tab, click on the Plan Cycles tab on the left of the screen.
  2. Click on the Add button to the right of the Plan Cycles grid.
  3. Enter the Period Start and Period End of the Plan Cycle and click Save.
    • If the period is a short plan year, a Short Plan Year box will appear. Check the box and click Save.
    • Note: users cannot create Plan Cycles with overlapping periods. 

Editing Plan Cycle Data from Plan Details: 

  1. From the Plan Details > Home tab, click on the Plan Cycles tab to the left of the screen.
  2. Double-click on the Plan Cycle period to edit.
  3. Click on the appropriate tab on the left of the General Plan Cycle Information screen.
  4. Click the Edit button to the right of the grid.
  5. Make the desired edits to the information in the slider menu, and click Save. 

Edit Plan Cycle Data for an Annual Administration Project: 

  1. Search for the Plan. 
  2. Double click on the Plan in the Plan column of the Search dashboard.
  3. Click on the Workflow tab.
  4. Double click on the correct Annual Administration Project.
  5. Click on the Plan Cycle tab.
  6. On the left, click on the appropriate tab and then click on the Edit button.
  7. Edit the information in the slider and click Save.

 

Importing Plan Cycle Data 

The most efficient way to update Plan Cycle Data is by importing it in bulk. Users can import Plan Cycle Data for multiple plans or multiple plan years at once using the Plan Cycle Import Power Tool.

Downloading a blank template

Importing the Plan Cycle Data requires that a blank Plan Cycle Data Template be exported from PensionPro following the steps below: 

  1. Click on the Power Tools>Import>Plan Cycle Data. 
  2. Click on the Export button and Save.

 

Exporting data from an external source

The second step is to export the Plan Cycle data from an external source. The information that is exported will need to be in an Excel spreadsheet and will need to have a column that matches the TPA Plan ID in PensionPro. 

 

Editing the Plan Cycle Data Template 

The third step is to organize and compile the data in the  Plan Cycle Data Template.  The template has two sheets; an Instructions sheet and a datasheet. For the import power tool to work properly, both the Instruction tab and Data tab must exist in the template. Additionally: 

  • The columns for TPA Plan ID and the Period End are required fields and must be populated for the import to work. 
  • The TPA Plan ID is the unique identifier used to match data in the import file with the appropriate plan in PensionPro.  The TPA Plan ID field is located on the Plan Details\Home\General Tab. 
  • The Period End column in the Plan Cycle Data Template must match a Period End for the Plan Cycle that exists for a Plan with the corresponding TPA Plan ID. 

 Please be sure to update list values in PensionPro to match the template before an import is attempted.  

Remember, the headers and column order must match the Plan Cycle Data Template for the import to work.  

 

Importing a completed Plan Cycle Data Template

The final step is to import the completed Plan Cycle Data Template. 

  1. From the Application Menu, click on Power Tools>Import>Plan Cycle Data. 
  2. On the Plan Cycle Data tab that appears, click on the ‘I want to’ dropdown to choose whether the information will fill in blank fields or overwrite all fields.
    • Fill in Blank Fields will not overwrite any existing data, but will populate any Plan Cycle fields that are blank. 
    • Override All Fields will ignore any existing data and populate all Plan Cycle fields exactly as displayed in the Plan Cycle Data Template 

    3. Click the Browse button to locate the completed Plan Cycle Data Template that needs to be imported. 

    4. Click the Import button to process the Plan Cycle Data Template. 

The system will identify if the data was successfully imported by displaying the total number of imported records on the Success tab. If there were any issues with the data being imported, the reasons will appear under the Failed tab.  No data will be imported until all error messages are resolved. 

 

 Feature feedback

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments